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Overview

This example problem is meant to demonstrate the design of a Reinforced Concrete building 

(G+13 Floor + Terrace + 1Basement Podium) structure which is located in Agra is subjected to 

floor loads, wind loads and seismic loads

Wind Design Data

Basic wind speed 47 m/sec 

Terrain Category  III 

Building Class A

Seismic Design Data

-Dual system (special reinforced concrete structural walls with special moment resisting 

frame) in both the directions

-Assigned to a seismic zone

-Soil Type

-Importance factor

-Response Reduction factor

III (Z=0.16)

II  (Medium Soil) 

1.2

5.0

Methodology

-Response spectrum analysis

Reinforced Concrete Building
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Overview

Step

00

Figure 1: RC Building Model 3D
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Step

00

4m

Figure 2: Typical Floor Plan
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Figure 3: Podium Floor Plan

Step

00 Podium Floor Plan
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Step

00

www.MidasUser.com

Elevation View

14×3m = 42m

2×3 m = 6m

Figure 4: Longitudinal Section
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RC Design Code :

IS 456-2000

www.MidasUser.com

Building Structure Elements

Applied Code

Applied Load

Concrete M30 For Beams 

Concrete M40 For Columns 

Concrete M40 For Walls 

Steel Fe415

Materials

Section ID Dimension Description

1 450x450mm Podium columns

2 300x800mm Building Columns

3 230x700mm Beam

4 230mm thick Walls

Load Description Intensity

Dead Load Self Weight

Typical Floor Load
Super imposed Dead Load 

Live load

4 kN/m2

2 kN/m2

Podium Floor
Super imposed Dead Load 

Live load

4 kN/m2

4 kN/m2

Roof Floor
Super imposed Dead Load

Live load

5.5 kN/m2

1.5 kN/m2

Wind Load X, Y direction IS 875 Part3

Earthquake Loads X, Y direction IS 1893-2016

Step

00 Details of the Reinforced Concrete Building
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Step

01

Procedure

Starting Midas Gen

1 Click on GEN icon > New Project

2 Check the units on the lower 
right corner of the screen.

2

1

1-1.Initialization of workspace

www.MidasUser.com

http://www.MidasUser.com/


Step

01

Procedure

Structure Tab > UCS/Plan > 

UCS > X-Y Plane

1 Set UCS to X-Y Plane > Origin

0,0,3

2 Click on Apply And OK

1

2

1-2.Setting UCS to XY Plane
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Step

01

Procedure

1 Add

2 Name it Global,

3 Add X grid lines

4 Relative 

Lines: 13@4

(13@4,Means 13 Grid lines at the 

spacing of 4m)

Generate the required gridline system

Structure Tab > UCS/Plan > Grids

> Define Line Grid > Add

1

4

2

6

3 5

1-3. Generation line grid

5 Add Y grid lines and

Relative Lines: 2@4,6,4,6,2@4

6 Click OK

A dialog box depicting the 

Gridlines appears. Click OK

www.MidasUser.com
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Step

02

Procedure

2 Type of Design: Concrete 

Standard: IS(RC)

DB: M30

3 Click OK

Similarly define M40 material 

property for columns and walls

Defining Material Properties

Properties Tab > Material > Material 

Properties

1 Add

3

2
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2-1. Defining the Material & Frame Section Properties (1)

1

3
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Step

02

Procedure

2 User

H= 0.45m 

B= 0.45m

Similarly define the other Frame 

Section Properties 

Building Column 300x800, 

Beam 230x700.

Defining Frame Section Properties

Properties Tab > Section > Section 

Properties > Add

1 Solid rectangle 

Name: Podium Column

3  Click [Apply]

4

1

2

3

Section Name Dimension

Podium

column
Podium Column 450x450mm

Building

column
Building Column 300x800mm

Beam Beam 230x700mm

www.MidasUser.com

2-1. Defining the Material & Frame Section Properties (2)
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Procedure

Step

02

1 For the Shear Walls 

And Slab Thickness:

Add a ‘Thickness’ Section 

Value

In-plane & Out-of plane= 0.23m 1

2 On creating the wall, it is 

Displayed in the dialog box

www.MidasUser.com

2

2-1. Defining Shear walls (3)

Defining Shear walls

Properties Tab > Section > Thickness

> Add
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Step

03

2

Procedure

Make sure that Intersect at 

nodes and Elements is on

To create a beam, click on nodal 

connectivity and select the origin

as the first point and draw till 

the last point. 

*Please make sure that 

Point Grid Snap is On

Generate the Beams 

Node/Element Tab > Create 

Elements

1 Select General beam/Tapered 

beam

2

1

3-1. Generation of Floor layout (1)
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Step

03

2

Procedure

Node/Element Tab > Divide 

Elements1     

3-1. Generation of Floor layout (1)

www.MidasUser.com

1

23

Select the elements as 

shown in the figure 

Click Unequal distance 

Element type : Frame

Distance : 4 m

Click on select single

1

4 Click apply

2

4

3

Note:

Depending upon the local 

axis from 𝑖𝑡ℎ and 𝑗𝑡ℎ of the 

element the offset distance 

can vary as 2 or 4 m.

http://www.MidasUser.com/


Step

03

2

Procedure

Make sure that Intersect at 

nodes and Elements is on

To create a beam, click on nodal 

connectivity and select the origin

as the first point and draw till 

the last point. 

Generate the Beams 

Node/Element Tab > Create 

Elements

1 Select General beam/Tapered 

beam

2

1

3-1. Generation of Floor layout (1)
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Step

03

2

Procedure

Node/Element Tab > Divide 

Elements1     

3-1. Generation of Floor layout (1)

www.MidasUser.com

1

23

Select the elements as 

shown in the figure 

Click equal distance 

Element type : Frame

Equal Distance 

Number of divisions : 2

Click on select single

1

4 Click apply

2

4

3
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Step

03

2

Procedure

Make sure that Intersect at 

nodes and Elements is on

To create a beam, click on nodal 

connectivity and select the origin

as the first point and draw till 

the last point. 

Generate the Beams 

Node/Element Tab > Create 

Elements

1 Select General beam/Tapered 

beam

2

1

3-1. Generation of Floor layout (1)
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Step

03

Procedure

1 Node/Element Tab> 

Extrude Elements

2 Node to Line elements, 

select Element Type as 

Beam

3 Translation Distance as 0,0,-3 

Along Z axis.

Generate Columns 

View Tab > Grid/Snap > 

UCS/GCS > Click GCS

4 Select all the nodes as shown 

in the figure

5 Click on Apply

41

3

2

3-1. Generation of Floor layout (2)

5
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Step

03

www.MidasUser.com

Procedure

3 Now from the Works Menu, 

Drag and Drop Interior

Building Column section 

Modify the Property of Columns:

( To Change the property of certain 

exterior columns to Interior)

1 Works> Properties > Section 

>Podium Column>Right 

Click > Active. 

Select the columns whose 

property has to be changed

as shown in the figure.

1

2

3-1. Generation of Floor layout (3)

View Tab >Display >Property

> Property Name

1

3

2

2
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Step

03

Procedure

Generation Shear Walls 12

4

3-1. Generation of Floor layout (4)

www.MidasUser.com

1 Select the elements as 

shown in the figure 

2 Extrude type : Line →

Planar element

Check in Remove to 

remove the line elements 

selected 

Material : M40

Thickness : 0.23

3 Generation type : Translate 

Distance : 0,0,-3

2

3
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Step

04

Procedure

1 Structure Tab > Control Data 

Building Generation

No of Copies: 1

Distance (Global Z): 3.0m

2 Click Add

Building Generation

View Tab > Select > Select All

3 Click on Apply

The building is generated as 

Shown

(podium is only up to two levels)

1

2

4-1. Generation of Building Model (1)

3
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Step

04

Procedure

1 View > View point > Rear (+Y)

2 Select elements as shown

3 Click on Active

4-1. Generation of Building Model (2)

1

www.MidasUser.com

1

2

3
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Step

04

Procedure

1 Structure Tab > Control Data

> Building Generation

No of Copies: 14

Distance (Global Z): 3.0 m

2 Click Add

Building Generation

View Tab > Select > Select 

by single > Select ground floor 

as shown

43 Click on Apply

4 The building is generated as 

Shown

4-1. Generation of Building Model (2)

1

2

3
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Procedure

Structure Tab > Control Data > 

Story

1 Click [Auto Generate Story Data] 
button. This will create the data 
needed to generate diaphragms 
for each floor

2 Click [OK]

Story data is generated

1

www.MidasUser.com

Step

04

2

4-2. Automatic generation of the story data
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Step

05

Procedure

1 Select the ends of all the columns

from the Front view.

The lower ends of the Columns 

are assumed fixed

Click “Select by window”

5-1. Boundary Conditions

1

2

2 Boundary Tab > Supports > 

Define Supports

3 Select the property of Fixed 

Support i.e. D- all, R- all.

3

4 Click on Apply

4

www.MidasUser.com
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Procedure

Step

06

2 Click : [Close]

Load Tab > Load Type >

Static Loads > Create Load Cases 

Static Load Cases

1 Add the loads and their details 

as shown in the Dialog box

2

6-1. Loading Data (1)

1

www.MidasUser.com
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Procedure

Step

06

Load Tab> Load Type >

Static Loads > Structural Loads/ 

Masses > Self Weight

1 Load Case Name: DL 

Z=-1

2 Add

3 In the Work Tree menu, Self

Weight will be displayed

3

1

2

6-1. Loading Data (2)

www.MidasUser.com
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Procedure

Similarly define these floor loads

Name: Podium Floor

DL: -4kN/m2

LL: -4kN/m2 

Name: Roof 

DL: -5.5kN/m2 

LL: -1.5kN/m2

1 Name: Typical Floor

DL: -4kN/m2 (Consider 100mm 
slab thickness, self weight 
added)

LL: -2kN/m2

Step

06

2 Click on Add

2

Load Tab > Initial Forces/Misc

> Assign Floor Load Type > Define 

floor load type

6-1. Loading Data (3)

1

www.MidasUser.com

2
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Procedure

Step

06

3  Click on Active

View Tab > Activities > All > Active 

Identity

1 Check on Story

Then Select 2F

2 Check on +Below

6-1. Loading Data (4)

1

www.MidasUser.com

2

3
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Procedure

Step

06

1

6-1. Loading Data (5)

www.MidasUser.com

Apply Floor Load to the Activated 

Floor

Load Tab > Initial Forces/Misc

> Assign Floor Loads

1 Name: Podium Floor

2 Copy Floor load: 1@3 

(Total 1 floor and each 

floor distance is 3.0m)

To select the floor area, first 

Select Nodes Defining Loading 

Area where in You need to 

Select the nodes . On the last 

Click, the load is applied.

2
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1 Name: Typical Floor

2 Copy Floor load: 14@3 

(Total 15 floors and each 

floor distance is 3.0m)

To select the floor area, first 

Select Nodes Defining Loading 

Area . On the last

Click, the load is applied

Step

06

Apply Floor Load to the Activated 

Floor

Load Tab > Initial Forces/Misc

> Assign Floor Loads

Procedure

2

1

6-1. Loading Data (6)
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Procedure

Step

06

3  Click on Active

View Tab > Activities > All > Active 

Identity

1 Check on Story

Then Select Roof

2 Check on +Above

6-1. Loading Data (4)

1

www.MidasUser.com

2

3
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1 Name: Typical Floor

2 Uncheck Copy Floor 

load 

To select the floor area, 

first Select Nodes 

Defining Loading Area . 

On the last

Click, the load is applied

Step

06

Apply Floor Load to the Activated 

Floor

Load Tab > Initial Forces/Misc

> Assign Floor Loads

Procedure

2

1

6-1. Loading Data (6)
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Procedure

1 Structure type: 3-D

Mass Control Parameter: 

Lumped Mass

Convert Self-Weight into

masses 

Convert to X,Y

Gravity Acceleration:

9.806m/sec2

Check beam section and 

slab section Alignment 

(X-Y Plane)

www.MidasUser.com

Step

06

Structure Tab > Structure type

6-2. Convert Model Weight & Loads to Masses (1)

1
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Procedure

Load Tab > Static Loads > 

Structure loads/Mass > 

Loads to Masses

1 Mass Direction: X,Y 

Load Case / Factor: 

DL: 1

Click Add 

SIDL: 1

Click Add 

LL: 0.25

Click Add

2 On clicking Ok

Such a model is generated

Step

06

1

2

www.MidasUser.com

6-2. Convert Model Weight & Loads to Masses (2)
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Procedure

Query Tab > Mass Summary 

Table 

1 Mass Summary can be

viewed in X,Y & Z Direction.

Step

06

1

www.MidasUser.com

6-2. Convert Model Weight & Loads to Masses (2)
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Procedure

Check wind load profile as if 

Required

For detail Calculation click on 

Make wind load calc. sheet

Step

06

2 The loads are summarized in 

the dialog box

Load Tab > Static Loads

> Wind Loads > Click [Add]

1 Load Case Name : WX

Wind Load Code : IS875(2015) 

Basic Wind Speed: 47m/s 

Terrain Category: III

Building Class: A

Wind Load Direction Factor 

for X: 1 rest all will

Be 0. Click Apply 

Similarly assign the Load 

parameters for WY

2
1

3

3
4

4

www.MidasUser.com

6-3. Wind Loads
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Procedure

Step

06

1 Fill in the details as shown.

For EXP Click on Positive

2 Calculating time period, use 

period Calculator for

Auto-calculation of periods 

from the code equations

As per IS 1893:2016 for RC

Structures without brick infill panel 

T= 0.075h^(0.75)

Load Tab > Static loads

> Seismic Loads

3 Similarly defining all the load 

Cases such a dialog box appears.

www.MidasUser.com

2

1

6-4. Static Seismic Loads

3
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Step

06

www.MidasUser.com

6-4. Static Seismic Loads

In X Direction: (5 WALLS)
Shear wall (1): (4 × 3) = 12 m²

Shear wall (2): (2 × 3) = 6 m²

AW1 = 12 × [0.2 + (4/48) ²]

AW1 = (2.48) × 2 = 4.96 m²

AW2 = 6 × [0.2 + (2/48) ²]

AW2 = (1.21) × 3 = 3.63 m²

AWT = AW1 + AW2  = 8.59 m²

Tₐ = 0.075 × 48 0.75 / √8.59 = 0.4666

Tₐ(min) = 0.09 × 48 / √52 = 0.599

→ 0.4666 ≱ 0.599 (Condition not satisfied)

In Y Direction: (2 WALLS)
AWT = 4.96 m²

Tₐ = 0.075 × 48 0.75 / √4.96 = 0.614

Tₐ(min) = 0.09 × 48 / √32 = 0.7636

→ 0.614 ≱ 0.7636 (Condition not satisfied)

NOTE:
Since the empirical period (Tₐ) is less
than the minimum value (Tₐ(min)) in
both X and Y directions, the condition
is not satisfied. Hence, the period to be
used for analysis shall be taken as
T = 0.09h/√d as per code
requirements.

http://www.MidasUser.com/


Procedure

Step

06

1 Seismic Load Profile

2 X-Dir (on)

Story shear (on)

Conform Story Shear of Base 

floor

Load Tab > Static Loads > 

Seismic Loads >

Select Load Case Name EXP >

Modify

1

3 Conform the Story Shear

4 For detail Earthquake load 

Calculation click on Make seismic 

Load Calc. sheet

4

www.MidasUser.com

6-4. Static Seismic Loads (Seismic Profile)

3

2
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Procedure

1 Add > Function Name: Design 

Spectrum

Generate Design Spectrum:   

Design Spectrum:IS1893(2016)     

Seismic Zone: III

Soil Type: II Importance Factor: 1

Response Reduction Factor: 5

Click OK

3 Such a Dialog Box appears. 

Click OK

The Response Spectrum function

 is generated

Step

06

2
1Load Tab > Dynamic Loads > 

Response Spectrum Data > 

Response Spectrum Function

3

6-5. Response Spectrum Functions

www.MidasUser.com

2

3
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1 Load Cases Name : SpecX 

Excitation Angle : 0

Step

06

2 Check : IS 1893(2016)

3 Click [Add]

4 Load Cases Name : SpecY 

Excitation Angle : 90

5 Click [Add]

The two Spectrum Load Cases 

Are created

Click Eigen Value Analysis 

Contol 3

* Auto-Search Angle (Principal Axis) 

Select this option to automatically take the 

excitation angle of response spectrum as the 

major-axis direction of a building.

"Major" and "Ortho" must be defined in the 

identical Response Spectrum function.

For example, if we define "RX" load case as 

"Major", "RY" load case must be defined as 

"Ortho". After performing the Response Spectrum 

Analysis, excitation angle of the structure will be 

automatically entered in the "Excitation Angle" 

field.

Load Tab > Seismic > Response 

Spectrum Data > Response 

Spectrum Load Cases

Procedure

5

41

2

www.MidasUser.com

6-6. Response Spectrum Load cases
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Step

06

1 Number of Frequencies : 20 

Then click OK

Analysis Tab> Eigen value Analysis

Control

1

Procedure

2 Analysis Tab > perform analysis

2

www.MidasUser.com

6.7. Eigen Analysis Control
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Procedure

Results Tab > Tables > Result 

Tables > Story > Story Shear 

(Response Spectrum Analysis) 

Spectrum Load Cases >Spec X(RS) 

(on) & Spec Y(RS) (on)

1 Compare RX(RY) with EX(EY)

1

7-1. Analysis of Results (1)

www.MidasUser.com

X-Direction Scale Up Factor

= Static seismic result / Dynamic analysis 

result

=4061.60 / 1357.5

=2.99

Y-Direction Scale Up Factor

= 3186.21 / 1431.1

=2.22

Step

07
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Procedure

Results Tab > Combination > 

Load Combination > Concrete 

Design

1 Select Concrete Design tab

2

4
2 Click Auto-Generation

3 Select Design Code 

as “IS456:2000 ”

4 Scale Up of Response Spectrum 
Load Cases

Scale Up Factor: Spec X 2.99 

Click Add

Scale Up Factor: Spec Y 2.22

Click Add and Click [OK]

3

7-1. Automatic generation of load combinations (2)

1

www.MidasUser.com

Step

07
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Results Tab > Results > Reaction

forces (or) moments

1

1 Load cases/combinations

CBC:cLCB 1

Procedure

2 Click on this to see Results in 

tabular format as shown below.

8-1.Verification of Reactions

2

www.MidasUser.com

Step

08
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Results Tab > Results

Deformations>Displacement contour

1 Load cases/combinations 

CBC:cLCB1

2 If  For Animation, click on 

Animate and Apply

1

2

8-2.Displacement contour

www.MidasUser.com

Procedure

Step

08
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2

8-3.Bending Moment Diagram

Procedure

Results Tab > Results > Forces >

Beam Diagrams
1

1 Load cases/combinations 

CBC:cLCB1

2 For Values, click on Values 

and Apply

www.MidasUser.com

Step

08
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Step

08

Procedure

1

Click on Apply

1 Select Mode 1

You can Select any mode 

shape from dropdown box

2

8-4.Vibration Mode Shape (1)

2

www.MidasUser.com

Results Tab > Tables > Results

Tables > Vibration Mode Shape
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Step

08

Results Tab > Mode Shapes >

Vibration Mode Shapes

Procedure

1

8-5.Modal Participation Masses

1 Click on the right side of Vibration 
Mode Shape

2 90% Modal Participation Masses 

In Mode 11, both x & y direction

www.MidasUser.com
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Step

09

Procedure

Results Tab > Results Table >

Story > Check Parameter

1 Select Country Code : 

IS1893(2016) and 

click ok
1

2 Select the Load Combination 

Type and click oke

Story Checks

www.MidasUser.com

3

1 3

2 Results > Results Table >

Story > Story Drift
2

2

2

2

2
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Step

09

Procedure

Results Tab > Results Table >

Story > Irregularity Check 

Parameter

Select Country Code : 

IS1893(2016) and 

click ok

1

2 Select the Load Combination 

Type and click ok.

www.MidasUser.com

3

1
3

2 Results > Results Table >

Story > Weight Irregularity Check
2

2

2

2

2

1

Story Checks
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Step

09

Procedure

Results Tab > Results Table >

Story > Irregularity Check 

Parameter

12 Select the Load Combination 

Type and click ok.

www.MidasUser.com

2

22 Results > Results Table >Story 

> Stiffness Irregularity Check
1

1

1

1
1

Story Checks
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Procedure

3  Click on Active

View Tab > Activities > All > Active 

Identity

1 Check on Story

Then Select Roof

2 Check on + Below

1

www.MidasUser.com

2

3

Step

09 Story Checks

1
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Step

09

Procedure

Results Tab > Story Shear  Force 

Ratio

2 Check on Ratio and Legends

and  Click Apply.

www.MidasUser.com

2

2 Select the Load Case : EXP1

1

2

Story Checks
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